La Suite de Fibonacci en Algorithmique [SI – POUR ]

La suite de Fibonacci est une suite d’entiers, souvent représenté et décrivant la croissance d’une population de lapins.

On peut citer :

« Un homme met un couple de lapins dans un lieu isolé de tous les côtés par un mur. Combien de couples obtient-on en un an si chaque couple engendre tous les mois un nouveau couple à compter du troisième mois de son existence ? »

Vous trouverez ci-joint le code en algorithmique pour cette suite mathématique

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
Programme fibonacci
Variable N , compteur , Un1 , Un2 , un : Entier

Début
|
| Afficher ( "veuillez saisir le rang de votre suite" )
| Saisir ( n )
| Si n > 1 Alors
| | un1 <- 1
| | un2 <- 1
| | Pour compteur <- 2 à n Faire
| | | un <- un1 + un2
| | | un2 <- un1
| | | un1 <- un
| | FinPour
| | Afficher ( "valeur de la suite (" & n & ") est " & un )
| Sinon
| | Afficher ( "Erreur de saisie, le programme est arrêté" )
| FinSi
|
Fin
Scan to Donate Bitcoin
Like this? Donate Bitcoin to at:
Bitcoin 17NmM8q9TC7f4eKczRzHFXTZd39S8K24dv
Donate

Laisser un commentaire

Assemblé dans la station orbitale WordPress