Analyse de Fonction en Algorithmique

On nous annonce, soit la fonction F(X) = -X^3+2 avec comme intervalle d’exemple [-1;2], écrire un programme demandant à l’utilisateur de saisir les valeurs a et b de l’intervalle d’étude, la précision recherchée p puis affichant la valeur X trouvée pour l’équation F(X)=0.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
Programme Analyse_Fonction
Variable a , b , p , x , y , ya , yb : Réel

Début
//Initialisation
  |  Répéter
  |    |  Afficher ( "Veuillez saisir la borne inférieure (a) de l'intervalle d'étude :" )
  |    |  Saisir ( a )
  |    |  Afficher ( "Veuillez saisir la borne supérieure (b) de l'intervalle d'étude :" )
  |    |  Saisir ( b )
  |    |  Si b <= a Alors
  |    |    |  Afficher ( "La borne b doit être supérieure à la borne a, veuillez recommencer la saisie." )
  |    |  FinSi
  |  Jusqu à b > a
  |  Répéter
  |    |  Afficher ( "Veuillez saisir la précision :" )
  |    |  Saisir ( p )
  |    |  Si b - a <= p Alors
  |    |    |  Afficher ( "La précision dépasse l'amplitude de l'intervalle (" & b - a & "), veuillez recommencer la saisie." )
  |    |  FinSi
  |  Jusqu à p < b - a
  |  
// Recherche de X0
  |  Répéter
  |    |  x <- ( a + b ) / 2
  |    |  y <- - x ^ 3 + 2
  |    |  yb <- - b ^ 3 + 2
  |    |  Si y * yb > 0 Alors
  |    |    |  b <- x
  |    |  Sinon
  |    |    |  a <- x
  |    |  FinSi
  |  Jusqu à b - a <= p
  |  Afficher ( "X0 = " & ( a + b ) / 2 )
Fin

Laisser un commentaire

Assemblé dans la station orbitale WordPress