Configurer le protocole OSPF avec Cisco Packet Tracer

logo cisco

Le protocole OSPF (Open Shortest Path First) est un protocole de routage par « état de liens« . Il est actuellement en Version 2 et peut être utilisé sur des réseau IPV6. OSPF permet d’obtenir une table de routage avec les meilleurs routes. La meilleure route ne sera pas forcement les plus courtes, mais la plus « rapide » on va faire appel à la notion de « métrique » définie comme un nombre de sauts.

Concrètement le protocole OSPF opère de la façon suivante. Le routeur découvre son voisinage et conserve une liste de tous ses voisins( Neighbor table), suite à cela il va calculer les meilleurs routes pour placer les meilleurs dans sa table de routage. Le routeur va également stocker la topologie du réseau (Topology database).

Pour débuter ce TP vous devez mettre en place la topologie suivante :

1
2
3
4
5
6
7
8
9
10
11
Router0: de modèle 2620XM
2 modules : WIC-1T
1 module : NM-4E

Router1: de modèle 2620XM
2 modules : WIC-1T
1 module : NM-4E

Router2: de modèle 2620XM
2 modules : WIC-1T
1 module : NM-4E

1 configuration physique routeur ospf

Pour mettre en place OSPF vos routeurs doivent être connecté sur un réseau spécifique, observez le schéma ci-dessous. On constate que chaque routeur correspond à un service sur mon schéma. Avec OSPF vous pouvez observer que un réseau assure la liaison entre deux routeurs.

On va donc commencer par configurer nos réseaux, avec notre station client.

1
2
3
4
5
6
7
8
9
10
11
12
->Routeur0(ZONE BLEU)
Router>en
Router#conf t
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.10.254 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#end
Router#write

->Client0(ZONE BLEU)
FastEthernet0/0 :192.168.10.10/255.255.255.0
Passerelle: 192.168.10.254
1
2
3
4
5
6
7
8
9
10
11
12
->Routeur1(ZONE VERTE)
Router>en
Router#conf t
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.11.254 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#end
Router#write

->Client1(ZONE VERTE)
FastEthernet0/0 :192.168.11.10/255.255.255.0
Passerelle: 192.168.11.254
1
2
3
4
5
6
7
8
9
10
11
12
->Routeur2(ZONE ROUGE)
Router>en
Router#conf t
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.12.254 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#end
Router#write

->Client2(ZONE Rouge)
FastEthernet0/0 :192.168.12.10/255.255.255.0
Passerelle: 192.168.12.254

2 configuration interface ethernet ospf

Nous avons à présent nos trois réseaux indépendants, c’est ici que l’on commence la configuration pour OSPF avec la mise en place des liens via les câbles series. (Via le module WIC-1T)

On commence donc par définir les plages d’adresses qui vont connecter entre eux nos routeurs, puis l’on passe à la configuration des interfaces sur nos trois routeurs.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
->Routeur0(ZONE BLEU)
Router>en
Router#conf t
Router(config)#interface Serial0/0
Router(config-if)#ip address 10.0.10.254 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#end
Router#write

->Routeur1(ZONE VERTE)
Router>en
Router#conf t
Router(config)#interface Serial0/0
Router(config-if)#ip address 10.0.10.253 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#end
Router#write

->Routeur2(ZONE ROUGE)
Router>en
Router#conf t
Router(config)#interface Serial0/0
Router(config-if)#ip address 10.0.10.252 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#end
Router#write

Pour tester votre configuration effectuez un ping entre votre interface serie, vous devriez obtenir ce type de résultat ci-dessous

3 ping interface serie ospf

Pour résumer le tout sur la configuration je vous propose de consulter ce screen ci-dessous ou à ce stade on ne peut ping les stations qu’avec les interfaces présentent sur leur réseau respectif.

4 configuration port serie OSPF

Mise en place du protocole de routage OSPF

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
->ROUTER0
Router#conf t
Router(config)#router ospf 1
Router(config-router)#network 192.168.10.0 0.0.0.255 area 0
Router(config-router)#network 192.168.11.0 0.0.0.255 area 0
Router(config-router)#network 10.0.10.0 0.0.0.255 area 0
Router(config-router)#end
Router#write

->ROUTER1
Router#conf t
Router(config)#router ospf 1
Router(config-router)#network 192.168.10.0 0.0.0.255 area 0
Router(config-router)#network 192.168.11.0 0.0.0.255 area 0
Router(config-router)#network 10.0.10.0 0.0.0.255 area 0
Router(config-router)#end
Router#write

5 mise en place ospf effective

Le protocole est maintenant en place, vous pouvez pinger vos stations X.X.10.0 vers X.x.11.0 et vise versa.

Vous pouvez consulter vos différentes routes et interface via,

1
2
3
show ip route
show ip ospf database
show ip ospf interface

Vous pouvez mettre en pratique OSPF sur le dernier routeur que vous avez installé en début de TP.

Add a comment »3 comments to this article

  1. Cehem1 | Pearltrees
  2. Importer et exporter une configuration de routeur ou switch avec TFTP | Laintimes
  3. Un joli tuto’ sur la mise en place de l’OSPF ! Je vais sans doute te le piquer ! :-)

    Répondre

Laisser un commentaire

Assemblé dans la station orbitale WordPress