Introduction aux tableaux en Algorithmique

Les tableaux en Algorithmique permettent de conserver un certain nombre de variables en incrémentant la valeur de l’indice de « variable tableau« .

algorithme

On peut ainsi utiliser des tableaux à plusieurs dimensions que l’on peut désigner comme une suite d’éléments. On va se représenter un tableau comme une suite de cases contentant chacune une valeur. Tout les éléments d’un tableau sont de même type.(Entier, réel, chaine)

La notion de case contenant une valeur doit être associé à une variable qualifiée avec un indice. On parle alors de variable indicées.(tableau[i])
Le tableau en lui même est constitué d’une variable. Seul l’indice va changer.

Exemple : Je déclare un tableau « note » qui comportera 3 notes.

1
Variable note : Réel [ 3 ]

On a donc une variable « note » avec un indice de 3, qui se traduit par un tableau à 3 cases, suivant l’appel que l’on va en faire on pourra appeler un élément précis du tableau.

Exemple :

1
2
3
4
Variable note : Réel [ 3 ]
note[1] <- 10
note[2] <- 20
note[3] <- 15

Afin de compléter ce tableau de variables il est plus facile d’utiliser une boucle suivant le besoin que vous avez.

Exemple :Toujours avec mon tableau de note et dans une boucle « Pour »

1
2
3
 Pour i <- 1 à 3 Faire
     |  Saisir ( note [ i ] )
 FinPour

Le script demande à l’utilisateur de rentrer une note autant de fois que j’ai de case dans mon tableau, je fais répéter ma boucle autant de tour que j’ai de note.

Ci-joint un algorithme qui demande à l’utilisateur de saisir 3 notes, comme déclaré puis me calcul la moyenne des notes et la retourne à l’utilisateur.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
Programme MoyenneNote

Variable note : Réel [ 3 ]
Variable moyenne : Entier
Variable i : Entier

Début
  |  moyenne <- 0
  |  Afficher ( "Saisir les notes de l'élève" )
  |  Pour i <- 1 à 3 Faire
  |    |  Saisir ( note [ i ] )
  |    |  Si i = 1 Alors
  |    |    |  moyenne <- note [ i ]
  |    |    |  Afficher ( "La note N°" & i & " de l'élève est :" & note [ i ] )
  |    |  Sinon
  |    |    |  moyenne <- ( moyenne + note [ i ] )
  |    |    |  Afficher ( "La note N°" & i & " de l'élève est :" & note [ i ] )
  |    |  FinSi
  |  FinPour
  |  Afficher ( "La moyenne de l'élève est de " & moyenne / ( i - 1 ) )
Fin
Scan to Donate Bitcoin
Like this? Donate Bitcoin to at:
Bitcoin 17NmM8q9TC7f4eKczRzHFXTZd39S8K24dv
Donate

Laisser un commentaire

Assemblé dans la station orbitale WordPress