Excel – Fonction RECHERCHEV pour de l’Auto-complétion

Pour effectuer une auto-complétion dans Excel la fonction RECHERCHEV conviendra parfaitement. La fonction recherche une chaine dans votre classeur Excel et complète votre cellule, vous pouvez compléter celle-ci avec SI pour afficher éventuellement un message d’erreur.

Syntaxe :

1
=RECHERCHEV(cellule_à_rechercher; Coordonnées_de_la_recherche; colonne_à_récuperer)

Exemple :

1
RECHERCHEV($B6; articles!$A$3:$E$18; 3);

Ici je recherche la valeur B6 dans ma feuille articles, entre les cellules A3 et E18 de cette même feuille en récupérant la cellule de la colonne 3.
Présentation de ma Feuille « Facture », on remarque les trois petits onglets en bas qui permette de naviguer au travers de mon classeur de feuilles.

Fonction RECHERCHEV sur ExcelFonction RECHERCHEV sur Excel

En complétant notre RECHERCHEV avec un SI, cela nous permet d’éviter les cellules avec un #N/A.

1
=SI($B6<>"Pas de valeur trouvée"; RECHERCHEV($B6;articles!$A$3:$E$18;3); "")
Scan to Donate Bitcoin
Like this? Donate Bitcoin to at:
Bitcoin 17NmM8q9TC7f4eKczRzHFXTZd39S8K24dv
Donate

Laisser un commentaire

Assemblé dans la station orbitale WordPress