VLAN de Niveau 3 Configurer des Sous-Reseau sur Cisco Packet Tracer

Il devient intéressant de créer des sous réseau pour faire communiquer des stations qui ne sont pas sur le même réseau et/ou sur le même VLans.

sous reseau cisco packet tracer

Dans la configuration du routeur il faut configurer en premier lieux vos sous interfaces. Opérez comme dans l’exemple ci-dessous, je pars de la base simple de deux VLAN (10 et 20).

logo cisco

Dans l’ordre de déroulement des commandes, je détail

  • - Positionnement sur une sous interface 0/0.1
  • - Attribution d’une adresse IP(192.168.X.254) et d’un masque(255.255.255.0)
  • - Description rapide de cette sous interface
  • - Retour
  • - Sauvegarde de vos configuration courante

VLAN 1

1
2
3
4
5
6
Router(config)#interface fa0/0.1
Router(config-subif)#ip add 192.168.10.254 255.255.255.0
Router(config-subif)#descr **VLAN1**
Router(config-subif)#encap dot1q 10
Router(config-subif)#exit
Router#write

VLAN 2

1
2
3
4
5
6
Router(config)#interface fa0/0.2
Router(config-subif)#ip add 192.168.20.254 255.255.255.0
Router(config-subif)#descr **VLAN2**
Router(config-subif)#encap dot1q 20
Router(config-subif)#exit
Router#write

Dans un deuxième temps, on passe nos sous réseaux en DHCP. Suivez la procédure ci-dessous pour le même exemple que ci-dessus. VLAN 10 et 20 suivez la procédure ci-dessous.

Dans l’ordre de déroulement des commandes.

  • - Je déclare un pool DHCP sur le vlan 10
  • - Je déclare le réseau concerné et son masque
  • - Je complète l’adresse de routeur par default pour les clients
  • - Retour
  • - Sauvegarde de la Configuration du Routeur

1
2
3
4
5
Router(config)#ip dhcp pool 10
Router(dhcp-config)#net 192.168.10.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.10.254
Router(dhcp-config)#exit
Router#write

1
2
3
4
5
Router(config)#ip dhcp pool 20
Router(dhcp-config)#net 192.168.20.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.20.254
Router(dhcp-config)#exit
Router#write

Vous avez maintenant votre routeur configuré pour deux VLANS, placez maintenant votre SWITCH et opérez de créer vos VLANS via la procédure ci-dessous.

Dans l’ordre de déroulement des commandes.

  • - Activation du mode avancé
  • - On passe en mode Configuration
  • – On rentre dans la gestion des VLANS
  • - On cré un vlan N°XX nomé XX

1
2
3
4
5
6
7
8
9
10
11
Switch>en
Switch#conf t
Switch#vlan database
Switch(vlan)#vlan 10 name premiervlan
VLAN 10 added:
    Name: premiervlan
Switch(vlan)#vlan 20 name deuxiemvlan
VLAN 20 added:
    Name: deuxiemvlan
Switch(vlan)#exit
Switch#write

Les Vlans sont maintenant en place sur votre switch, on va passer par une configuration par port du switch. On configure donc 3 ports de notres switch. 1 pour notre routeur, 1 pour notre client situé dans le VLAN 10 du réseau 192.168.10.0 et 1 pour le deuxième client situé dans le VLAN 20 du réseau 192.168.20.0

Suivez la procédure ci-dessous.
Dans l’ordre de déroulement des commandes.

  • - Activation du mode avancé
  • - On passe en mode configuration
  • - On se place sur l’interface 0/1
  • - On change le mode du port en Trunk pour notre routeur
  • - On démarre l’interface
  • - Retour
  • - Retour
  • - Sauvegarde de votre configuration

1
2
3
4
5
6
7
8
Switch>en
Switch#conf t
Switch(config)#interface FastEthernet0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#exit
Switch#write

1
2
3
4
5
6
7
8
9
10
Switch(config)#interface FastEthernet0/2
Switch(config-if)#
Switch(config-if)#switchport mode access
Switch(config-if)#
Switch(config-if)#
Switch(config-if)#switchport access vlan 10
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#exit
Switch#write

1
2
3
4
5
6
7
8
9
10
Switch(config)#interface FastEthernet0/3
Switch(config-if)#
Switch(config-if)#switchport mode access
Switch(config-if)#
Switch(config-if)#
Switch(config-if)#switchport access vlan 20
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#exit
Switch#write


Votre Configuration est prête, connectez correctement vos stations, vos stations peuvent maintenant se pinger avec chacune son VLAN.

1
2
3
ROUTEUR : XXX : Reseau ..X.X : Port 0/1 sur le switch
PC1 : VLAN 10 : Reseau ..10.0 : Port 0/2 sur le switch
PC2 : VLAN 20 : Reseau ..20.0 : Port 0/3 sur le switch

Add a comment »3 comments to this article

  1. c’est très très bien. Cool.
    Mais si je veux mettre un serveur 2008 r2 sur ce réseau et que je souhaites activer AD, Dhcp, il n’y aura un conflits d’adresse ip ? Comment faire, quelle solution.
    merci

    Répondre

  2. ok … tres bon

    Répondre

  3. très cool

    Répondre

Laisser un commentaire

Assemblé dans la station orbitale WordPress