Script algorithmique de calcul de sous-réseaux

algorithmique

Dans le cadre des projets personnalisés encadrés (PPE) il peut vous êtes demandé de faire un algorithme. Dans ce billet je propose un script en langage algorithmique qui va retourner la liste de sous réseaux, l’adresse ip de la première et dernière machine ainsi que l’adresse de broadcast du sous-réseaux.

Le script utilise les notions de procédure, de classe, de fonction et de type qui sont toutes abordées dans le cadre du programme du BTS SIO.
Libre à vous de le récupérer et de le modifier. Vous pouvez utiliser des logiciels de simulation afin de générer un pseudo-code depuis vos algorithme afin de les tester. Je vous conseil le logiciel Pratiquer l’Algorithmique qui vous permet nombres d’options.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
519
520
521
522
523
524
525
526
527
528
529
530
531
532
533
534
535
536
537
538
539
540
541
542
Type struct_add
  |  octet_1 : Entier
  |  octet_2 : Entier
  |  octet_3 : Entier
  |  octet_4 : Entier
FinType

Type SR
  |  num_ss_rsx : Entier
  |  ss_rsx : struct_add
  |  adr_debut : struct_add
  |  adr_fin : struct_add
  |  adr_broad : struct_add
FinType

Variable LISTE_SR : SR

Programme recherche_sous_réseaux
' -----variable pour le programme----------------------------------------------------------------------------------------------------------------
Variable Nbr_sous_reseaux : Entier
Variable MonAdresse : struct_add
Variable classe : Chaîne
Variable letype : Chaîne
Variable addr2 : struct_add
Variable Nbr_hote_sous_reseaux : Entier
Variable nbr_bit_sous_reseau : Entier
Variable nbr_bit_addr_octet_mixte : Entier
Variable numéro_octet_mixte : Entier
Variable Masque : struct_add
Début
'
----Saisi des informations-----------------------------------------------------------------------------------------------------------------
  |  test_adresseIP ( MonAdresse.octet_1 , MonAdresse.octet_2 , MonAdresse.octet_3 , MonAdresse.octet_4 , Nbr_sous_reseaux )
' ------calcul des sous réseaux---------------------------------------------------------------------------------------------------------------
  |  classe <- calcul_classe ( MonAdresse.octet_1 )
'
------si la classe est valide alors on poursuit ---------------------------------------------------------------------------------------------
  |  Si classe <> "0" Alors
  |    |  calcul_réseau ( classe , MonAdresse.octet_1 , MonAdresse.octet_2 , MonAdresse.octet_3 , addr2.octet_1 , addr2.octet_2 , addr2.octet_3 , addr2.octet_4 )
  |    |  calcul_type_adresse ( classe , addr2.octet_1 , addr2.octet_2 , letype )
  |    |  calcul_bit_sous_réseaux ( classe , Nbr_sous_reseaux , nbr_bit_sous_reseau )
' -------si le nombre de sous réseau est incorrect on arrete le traitement---------------------------------------------------------------------
  |    |  Si nbr_bit_sous_reseau < 0 Alors
  |    |    |  Afficher ( "trop de sous réseaux pour cette classe, veuillez choisir un autre réseaux ou réduire le nombre de sous réseaux" )
  |    |  Sinon
  |    |    |  calcul_Masque_sous_réseaux ( classe , nbr_bit_sous_reseau , numéro_octet_mixte , Masque.octet_1 , Masque.octet_2 , Masque.octet_3 , Masque.octet_4 , nbr_bit_addr_octet_mixte )
  |    |    |  calcul_nombre_hote_par_sous_réseaux ( classe , nbr_bit_sous_reseau , Nbr_hote_sous_reseaux )
  |    |    |  remplissage_liste_sous_réseaux ( classe , numéro_octet_mixte , nbr_bit_addr_octet_mixte , addr2.octet_1 , addr2.octet_2 , addr2.octet_3 )
  |    |  FinSi
  |  Sinon
  |    |  Afficher ( "votre adresse n'
est pas valide, veuillez recommencer." )
  |  FinSi
  |  Afficher ( "
Fin de l'execution." )
Fin

Procédure test_adresseIP ( R octet_1 : Entier ; R octet_2 : Entier ; R octet_3 : Entier ; R octet_4 : Entier ; R Nbr_sous_reseaux : Entier )
Variable adresseip : Chaîne
Variable courte : Chaîne
Variable char : Chaîne
Variable longueur : Entier
Variable position : Entier
Variable a : Entier
Variable x : Entier
Variable y : Entier
Variable z : Entier
Variable test : Booléen
Variable test2 : Booléen
Début
  |  test2 <- Faux
  |  TantQue test2 = Faux Faire
  |    |  test <- Faux
  |    |  test2 <- Vrai
  |    |  TantQue test = Faux Faire
  |    |    |  Afficher ( " veuillez saisir une adresse ip svp " )
  |    |    |  Saisir ( adresseip )
  |    |    |  Si ( LgChaîne ( adresseip ) > 6 ) Et ( LgChaîne ( adresseip ) < 16 ) Alors
  |    |    |    |  test <- Vrai
  |    |    |  Sinon
  |    |    |    |  Afficher ( "mauvais format d'
adresse, veuillez recommencer" )
  |    |    |  FinSi
  |    |  FinTantQue
  |    |  z <- 0
  |    |  Pour y <- 1 à LgChaîne ( adresseip ) Faire
  |    |    |  char <- SousChaîne ( adresseip , y , 1 )
  |    |    |  Selon char
  |    |    |    |  Cas "
."
  |    |    |    |    |  z <- z + 1
  |    |    |    |  Cas "
1"
  |    |    |    |  Cas "
2"
  |    |    |    |  Cas "
3"
  |    |    |    |  Cas "
4"
  |    |    |    |  Cas "
5"
  |    |    |    |  Cas "
6"
  |    |    |    |  Cas "
7"
  |    |    |    |  Cas "
8"
  |    |    |    |  Cas "
9"
  |    |    |    |  Cas "
0"
  |    |    |    |  Cas Autre
  |    |    |    |    |  test2 <- Faux
  |    |    |  FinSelon
  |    |  FinPour
  |    |  Si test2 = Vrai Alors
  |    |    |  Si z < 4 Alors
  |    |    |    |  x <- 1
  |    |    |    |  TantQue x < 5
  |    |    |    |    |  Selon x
  |    |    |    |    |    |  Cas 1
  |    |    |    |    |    |    |  position <- PositionChaîne ( "
." , adresseip )
  |    |    |    |    |    |    |  longueur <- LgChaîne ( adresseip )
  |    |    |    |    |    |    |  courte <- DébutChaîne ( adresseip , position )
  |    |    |    |    |    |    |  a <- EnNumérique ( courte )
  |    |    |    |    |    |    |  octet_1 <- a
  |    |    |    |    |    |  Cas 2
  |    |    |    |    |    |    |  position <- PositionChaîne ( "
." , adresseip )
  |    |    |    |    |    |    |  longueur <- LgChaîne ( adresseip )
  |    |    |    |    |    |    |  courte <- DébutChaîne ( adresseip , position )
  |    |    |    |    |    |    |  a <- EnNumérique ( courte )
  |    |    |    |    |    |    |  octet_2 <- a
  |    |    |    |    |    |  Cas 3
  |    |    |    |    |    |    |  position <- PositionChaîne ( "
." , adresseip )
  |    |    |    |    |    |    |  longueur <- LgChaîne ( adresseip )
  |    |    |    |    |    |    |  courte <- DébutChaîne ( adresseip , position )
  |    |    |    |    |    |    |  a <- EnNumérique ( courte )
  |    |    |    |    |    |    |  octet_3 <- a
  |    |    |    |    |    |  Cas 4
  |    |    |    |    |    |    |  a <- EnNumérique ( adresseip )
  |    |    |    |    |    |    |  octet_4 <- a
  |    |    |    |    |  FinSelon
  |    |    |    |    |  adresseip <- SousChaîne ( adresseip , position , ( longueur - position + 1 ) )
  |    |    |    |    |  adresseip <- SousChaîne ( adresseip , 2 , longueur - position + 1 )
  |    |    |    |    |  x <- x + 1
  |    |    |    |  FinTantQue
  |    |    |    |  Si octet_1 > 0 Et octet_1 < 256 Et octet_2 > - 1 Et octet_2 < 256 Et octet_3 > - 1 Et octet_3 < 256 Et octet_4 > - 1 Et octet_4 < 256 Alors
  |    |    |    |    |  
  |    |    |    |  Sinon
  |    |    |    |    |  Afficher ( "
mauvaise valeur d'adresse" )
  |    |    |    |    |  test2 <- Faux
  |    |    |    |  FinSi
  |    |    |  Sinon
  |    |    |    |  Afficher ( "trop d'
octets" )
  |    |    |    |  test2 <- Faux
  |    |    |  FinSi
  |    |  Sinon
  |    |    |  Afficher ( "
pas de lettre SVP" )
  |    |    |  test2 <- Faux
  |    |  FinSi
  |    |  Si test2 = Faux
  |    |    |  Afficher ( "
recommencez !" )
  |    |  FinSi
  |  FinTantQue
  |  test <- Faux
  |  TantQue test = Faux Faire
  |    |  Afficher ( "
veuillez entrer le nombre de sous réseau voulu" )
  |    |  test <- Vrai
  |    |  Saisir ( Nbr_sous_reseaux )
  |    |  Si Nbr_sous_reseaux < 0 Alors
  |    |    |  test <- Faux
  |    |    |  Afficher ( "
veuillez insérer un nombre positif" )
  |    |  FinSi
  |  FinTantQue
Fin


Fonction calcul_classe ( num : Entier ) : Chaîne
' -------- le calcul se fait en Fonction de la valeur des deux premier octets , la valeur 0 signifie une erreur
Variable temp : Chaîne
Début
  |  Si ( ( num > 0 ) Et ( num < 127 ) ) Alors
  |    |  temp <- "
A"
  |  Sinon
  |    |  Si ( ( num > 127 ) Et ( num < 192 ) ) Alors
  |    |    |  temp <- "
B"
  |    |  Sinon
  |    |    |  Si ( ( num > 191 ) Et ( num < 224 ) ) Alors
  |    |    |    |  temp <- "
C"
  |    |    |  Sinon
  |    |    |    |  temp <- "
0"
  |    |    |  FinSi
  |    |  FinSi
  |  FinSi
  |  Retourner ( temp )
Fin

Procédure calcul_réseau ( D classe1 : Chaîne ; D octet_1 : Entier ; D octet_2 : Entier ; D octet_3 : Entier ; R oct1 : Entier ; R oct2 : Entier ; R oct3 : Entier ; R oct4 : Entier )
' ---------------on récupére la partie réseau de l'adresse fournie en Fonction de la classe d'adresse ip ----------------------------------------
Début
  |  oct1 <- 0
  |  oct2 <- 0
  |  oct3 <- 0
  |  oct4 <- 0
  |  Selon classe1
  |    |  Cas "
A"
  |    |    |  oct1 <- octet_1
  |    |  Cas "
B"
  |    |    |  oct1 <- octet_1
  |    |    |  oct2 <- octet_2
  |    |  Cas "
C"
  |    |    |  oct1 <- octet_1
  |    |    |  oct2 <- octet_2
  |    |    |  oct3 <- octet_3
  |  FinSelon
Fin

Procédure calcul_type_adresse ( D classe : Chaîne ; D octet_1 : Entier ; D octet_2 : Entier ; R lachaine : Chaîne )
' --------------- en fonction de la valeur des octets d'adresses, on vérifie si l'adersse est publique ou privée--------------
Début
  |  Selon classe
  |    |  Cas "
A"
  |    |    |  Si octet_1 = 10 Alors
  |    |    |    |  lachaine <- "
privée"
  |    |    |  Sinon
  |    |    |    |  lachaine <- "
publique"
  |    |    |  FinSi
  |    |  Cas "
B"
  |    |    |  Si ( octet_1 = 172 ) Et ( octet_2 > 15 ) Et ( octet_2 < 32 ) Alors
  |    |    |    |  lachaine <- "
privée"
  |    |    |  Sinon
  |    |    |    |  lachaine <- "
publique"
  |    |    |  FinSi
  |    |  Cas "
C"
  |    |    |  Si ( octet_1 = 192 ) Et ( octet_2 = 168 ) Alors
  |    |    |    |  lachaine <- "
privée"
  |    |    |  Sinon
  |    |    |    |  lachaine <- "
publique"
  |    |    |  FinSi
  |  FinSelon
Fin

Procédure calcul_bit_sous_réseaux ( D classe : Chaîne ; D nbssrsx : Entier ; R nbr_bit_sous_reseau : Entier )
' ----- on calcul le nombre de bit possible au maximum pour faire des sous réseaux en fonction de la classe------------------------------------------
Variable x : Entier
Variable y : Entier
Début
  |  x <- 0
  |  y <- 0
  |  Répéter
  |    |  x <- x + 1
  |    |  y <- 2 ^ x
  |  Jusqu'à ( ( y = nbssrsx ) Ou ( y > nbssrsx ) )
' ici x a le nombre de bit pour la partie adressage réseaux, on vérifie en fonction de la classe si le nombre de bit machine n'est pas trop important
  |  nbr_bit_sous_reseau <- x
  |  Selon classe
  |    |  Cas "
A"
  |    |    |  Si ( x > 22 ) Alors
  |    |    |    |  nbr_bit_sous_reseau <- - 1
  |    |    |  FinSi
  |    |  Cas "
B"
  |    |    |  Si ( x > 14 ) Alors
  |    |    |    |  
  |    |    |    |  nbr_bit_sous_reseau <- - 1
  |    |    |  FinSi
  |    |  Cas "
C"
  |    |    |  Si ( x > 6 ) Alors
  |    |    |    |  nbr_bit_sous_reseau <- - 1
  |    |    |  FinSi
  |  FinSelon
Fin

Procédure calcul_Masque_sous_réseaux ( D classe : Chaîne ; D nb_bit_ss_rsx : Entier ; R numéro_octet_mixte : Entier ; R octet_1 : Entier ; R octet_2 : Entier ; R octet_3 : Entier ; R octet_4 : Entier ; R nbr_bit_addr_octet_mixte : Entier )
' --------------  en fonction de la classe et du nombre de bot de sous réseau, on calcul le masque de sous réseau, le numéros de l'octet mixte indique quel octet est partagé entre bit adresse et bit machine-------------------------------------
Variable temp : Entier
Début
' calcul du masque de sous réseau
  |  octet_1 <- 0
  |  octet_2 <- 0
  |  octet_3 <- 0
  |  octet_4 <- 0
  |  Selon classe
  |    |  Cas "
A"
  |    |    |  octet_1 <- 255
  |    |    |  Si nb_bit_ss_rsx < 9 Alors
  |    |    |    |  numéro_octet_mixte <- 2
  |    |    |  Sinon
  |    |    |    |  Si ( ( nb_bit_ss_rsx > 8 ) Et ( nb_bit_ss_rsx < 17 ) ) Alors
  |    |    |    |    |  octet_2 <- 255
  |    |    |    |    |  numéro_octet_mixte <- 3
  |    |    |    |  Sinon
  |    |    |    |    |  octet_2 <- 255
  |    |    |    |    |  octet_3 <- 255
  |    |    |    |    |  numéro_octet_mixte <- 4
  |    |    |    |  FinSi
  |    |    |  FinSi
  |    |  Cas "
B"
  |    |    |  octet_1 <- 255
  |    |    |  octet_2 <- 255
  |    |    |  Si nb_bit_ss_rsx < 9 Alors
  |    |    |    |  numéro_octet_mixte <- 3
  |    |    |  Sinon
  |    |    |    |  Masque.octet_3 <- 255
  |    |    |    |  numéro_octet_mixte <- 4
  |    |    |  FinSi
  |    |  Cas "
C"
  |    |    |  octet_1 <- 255
  |    |    |  octet_2 <- 255
  |    |    |  octet_3 <- 255
  |    |    |  numéro_octet_mixte <- 4
  |  FinSelon
  |  nbr_bit_addr_octet_mixte <- Modulo ( nb_bit_ss_rsx , 8 )
  |  Selon nbr_bit_addr_octet_mixte
  |    |  Cas 1
  |    |    |  temp <- 128
  |    |  Cas 2
  |    |    |  temp <- 192
  |    |  Cas 3
  |    |    |  temp <- 224
  |    |  Cas 4
  |    |    |  temp <- 240
  |    |  Cas 5
  |    |    |  temp <- 248
  |    |  Cas 6
  |    |    |  temp <- 252
  |    |  Cas 7
  |    |    |  temp <- 254
  |    |  Cas 0
  |    |    |  temp <- 255
  |    |    |  nbr_bit_addr_octet_mixte <- 8
  |  FinSelon
  |  Selon numéro_octet_mixte
  |    |  Cas 2
  |    |    |  Masque.octet_2 <- temp
  |    |  Cas 3
  |    |    |  Masque.octet_3 <- temp
  |    |  Cas 4
  |    |    |  Masque.octet_4 <- temp
  |  FinSelon
' Afficher ( nbr_bit_addr_octet_mixte )
' Afficher ( numéro_octet_mixte )  |
Fin

Procédure calcul_nombre_hote_par_sous_réseaux ( D classe : Chaîne ; D nbr_bit_sous_reseau : Entier ; R Nbr_hote_sous_reseaux : Entier )
' ----------------- on calcul le nombre de d'hote maximum par sous réseau -----------------------------------
Variable temp : Entier
Variable temp2 : Entier
Début
  |  Selon classe
  |    |  Cas "
A"
  |    |    |  temp <- 8
  |    |  Cas "
B"
  |    |    |  temp <- 16
  |    |  Cas "
C"
  |    |    |  temp <- 24
  |  FinSelon
  |  temp2 <- 32 - nbr_bit_sous_reseau - temp
  |  Nbr_hote_sous_reseaux <- ( ( 2 ^ temp2 ) - 2 )
Fin

Procédure remplissage_liste_sous_réseaux ( classe : Chaîne ; numéro_octet_mixte : Entier ; nbr_bit_addr_octet_mixte : Entier ; octet_1 : Entier ; octet_2 : Entier ; octet_3 : Entier )
' ------ on calcul une valeur de saut pour passer d'un sous réseau à l'autre. On prend en compte le dépassement en incrémentant l'octet suivant. On compléte les autres informations à partir de l'adresse calculée. -----------------------------------
Variable x : Entier
Variable tampon1 : Réel
Variable tampon2 : Réel
Variable tampon3 : Réel
Variable le_numéros_du_sous_reseaux : Chaîne
Variable ladresse_du_sous_reseaux : Chaîne
Variable la_premiere_machine : Chaîne
Variable la_derniere_machine : Chaîne
Variable le_broadcast : Chaîne
Début
' ---------affichage des sous réseaux-----------------------------------------------------------------------------------------------------------------------------------------
' affichage de tout les informations avant le calcul des lignes
  |  Afficher ( "
Classe :" , classe )
  |  Afficher ( "
réseau principale :" , addr2.octet_1 , "." , addr2.octet_2 , "." , addr2.octet_3 , "." , addr2.octet_4 )
  |  Afficher ( "
type d'adresse :" , letype )
  |  Selon classe
  |    |  Cas "A"
  |    |    |  Afficher ( "nombre d'
hote disponible du réseau principal : 16777214" )
  |    |  Cas "
B"
  |    |    |  Afficher ( "
nombre d'hote disponible du réseau principal : 65534" )
  |    |  Cas "C"
  |    |    |  Afficher ( "nombre d'
hote disponible du réseau principal : 254" )
  |  FinSelon
  |  Afficher ( "
Masque de sous réseau : " , Masque.octet_1 , "." , Masque.octet_2 , "." , Masque.octet_3 , "." , Masque.octet_4 )
  |  Afficher ( "
Nombre d'hôte par sous réseaux : " , Nbr_hote_sous_reseaux )
  |  Afficher ( "liste des sous réseaux " )
  |  x <- 1
  |  Répéter
  |    |  tampon1 <- 0
  |    |  tampon2 <- 0
  |    |  tampon3 <- 0
  |    |  LISTE_SR.num_ss_rsx <- ( x - 1 )
'
on rentre le sous réseau, en ajoutant pour chaque boucle la valeur de saut --------------------------------------------------------------------------------------------------------------------------------------------
  |    |  Selon classe
  |    |    |  Cas "A"
  |    |    |    |  LISTE_SR.ss_rsx.octet_1 <- octet_1
  |    |    |    |  LISTE_SR.ss_rsx.octet_2 <- 0
  |    |    |    |  LISTE_SR.ss_rsx.octet_3 <- 0
  |    |    |    |  LISTE_SR.ss_rsx.octet_4 <- 0
' ajout de la valeur de saut --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
  |    |    |    |  tampon1 <- ( ( 2 ^ ( 8 - nbr_bit_addr_octet_mixte ) ) * ( x - 1 ) )
  |    |    |    |  Si numéro_octet_mixte = 2 Alors
  |    |    |    |    |  
  |    |    |    |    |  LISTE_SR.ss_rsx.octet_2 <- tampon1
  |    |    |    |  Sinon
  |    |    |    |    |  Si numéro_octet_mixte = 3 Alors
  |    |    |    |    |    |  
  |    |    |    |    |    |  Si tampon1 < 256 Alors
  |    |    |    |    |    |    |  LISTE_SR.ss_rsx.octet_3 <- tampon1
  |    |    |    |    |    |  Sinon
  |    |    |    |    |    |    |  LISTE_SR.ss_rsx.octet_2 <- DivEnt ( tampon1 , 256 )
  |    |    |    |    |    |    |  tampon2 <- Modulo ( tampon1 , 256 )
  |    |    |    |    |    |    |  LISTE_SR.ss_rsx.octet_3 <- tampon2
  |    |    |    |    |    |  FinSi
  |    |    |    |    |  Sinon
  |    |    |    |    |    |  Si numéro_octet_mixte = 4 Alors
  |    |    |    |    |    |    |  Si tampon1 < 256 Alors
  |    |    |    |    |    |    |    |  LISTE_SR.ss_rsx.octet_4 <- tampon1
  |    |    |    |    |    |    |  Sinon
  |    |    |    |    |    |    |    |  tampon2 <- DivEnt ( tampon1 , 256 )
  |    |    |    |    |    |    |    |  Si tampon2 < 256 Alors
  |    |    |    |    |    |    |    |    |  tampon2 <- Modulo ( tampon1 , 256 )
  |    |    |    |    |    |    |    |    |  LISTE_SR.ss_rsx.octet_3 <- DivEnt ( tampon1 , 256 )
  |    |    |    |    |    |    |    |    |  LISTE_SR.ss_rsx.octet_4 <- tampon2
  |    |    |    |    |    |    |    |  Sinon
  |    |    |    |    |    |    |    |    |  LISTE_SR.ss_rsx.octet_2 <- DivEnt ( ( tampon1 / 256 ) , 256 )
  |    |    |    |    |    |    |    |    |  LISTE_SR.ss_rsx.octet_3 <- DivEnt ( tampon2 , 256 )
  |    |    |    |    |    |    |    |    |  tampon3 <- Modulo ( tampon2 , 256 )
  |    |    |    |    |    |    |    |    |  LISTE_SR.ss_rsx.octet_4 <- tampon3
  |    |    |    |    |    |    |    |  FinSi
  |    |    |    |    |    |    |  FinSi
  |    |    |    |    |    |  FinSi
  |    |    |    |    |  FinSi
  |    |    |    |  FinSi
  |    |    |  Cas "B"
  |    |    |    |  LISTE_SR.ss_rsx.octet_1 <- octet_1
  |    |    |    |  LISTE_SR.ss_rsx.octet_2 <- octet_2
  |    |    |    |  LISTE_SR.ss_rsx.octet_3 <- 0
  |    |    |    |  LISTE_SR.ss_rsx.octet_4 <- 0
  |    |    |    |  
  |    |    |    |  tampon1 <- ( ( 2 ^ ( 8 - nbr_bit_addr_octet_mixte ) ) * ( x - 1 ) )
  |    |    |    |  Si numéro_octet_mixte = 3 Alors
  |    |    |    |    |  
  |    |    |    |    |  LISTE_SR.ss_rsx.octet_3 <- tampon1
  |    |    |    |  Sinon
  |    |    |    |    |  Si tampon1 < 256 Alors
  |    |    |    |    |    |  LISTE_SR.ss_rsx.octet_3 <- tampon1
  |    |    |    |    |  Sinon
  |    |    |    |    |    |  LISTE_SR.ss_rsx.octet_3 <- DivEnt ( tampon1 , 256 )
  |    |    |    |    |    |  tampon2 <- Modulo ( tampon1 , 256 )
  |    |    |    |    |    |  LISTE_SR.ss_rsx.octet_4 <- tampon2
  |    |    |    |    |  FinSi
  |    |    |    |  FinSi
  |    |    |  Cas "C"
  |    |    |    |  LISTE_SR.ss_rsx.octet_1 <- octet_1
  |    |    |    |  LISTE_SR.ss_rsx.octet_2 <- octet_2
  |    |    |    |  LISTE_SR.ss_rsx.octet_3 <- octet_3
  |    |    |    |  LISTE_SR.ss_rsx.octet_4 <- 0
  |    |    |    |  tampon1 <- ( ( 2 ^ ( 8 - nbr_bit_addr_octet_mixte ) ) * ( x - 1 ) )
  |    |    |    |  LISTE_SR.ss_rsx.octet_4 <- tampon1
  |    |  FinSelon
'
on remplit la case adresse début --------------------------------------------------------------------------------------------------------------------------------------------
  |    |  LISTE_SR.adr_debut.octet_1 <- LISTE_SR.ss_rsx.octet_1
  |    |  LISTE_SR.adr_debut.octet_2 <- LISTE_SR.ss_rsx.octet_2
  |    |  LISTE_SR.adr_debut.octet_3 <- LISTE_SR.ss_rsx.octet_3
  |    |  LISTE_SR.adr_debut.octet_4 <- LISTE_SR.ss_rsx.octet_4 + 1
' on remplit la case dernière adresse : adr_fin --------------------------------------------------------------------------------------------------------------------------------------------
  |    |  Selon classe
  |    |    |  Cas "A"
  |    |    |    |  Si numéro_octet_mixte = 2 Alors
  |    |    |    |    |  LISTE_SR.adr_fin.octet_1 <- LISTE_SR.ss_rsx.octet_1
  |    |    |    |    |  LISTE_SR.adr_fin.octet_2 <- LISTE_SR.ss_rsx.octet_2 + ( 2 ^ ( 8 - nbr_bit_addr_octet_mixte ) ) - 1
  |    |    |    |    |  LISTE_SR.adr_fin.octet_3 <- 255
  |    |    |    |    |  LISTE_SR.adr_fin.octet_4 <- 254
  |    |    |    |  Sinon
  |    |    |    |    |  Si numéro_octet_mixte = 3 Alors
  |    |    |    |    |    |  LISTE_SR.adr_fin.octet_1 <- LISTE_SR.ss_rsx.octet_1
  |    |    |    |    |    |  LISTE_SR.adr_fin.octet_2 <- LISTE_SR.ss_rsx.octet_2
  |    |    |    |    |    |  LISTE_SR.adr_fin.octet_3 <- LISTE_SR.ss_rsx.octet_3 + ( 2 ^ ( 8 - nbr_bit_addr_octet_mixte ) ) - 1
  |    |    |    |    |    |  LISTE_SR.adr_fin.octet_4 <- 254
  |    |    |    |    |  Sinon
  |    |    |    |    |    |  LISTE_SR.adr_fin.octet_1 <- LISTE_SR.ss_rsx.octet_1
  |    |    |    |    |    |  LISTE_SR.adr_fin.octet_2 <- LISTE_SR.ss_rsx.octet_2
  |    |    |    |    |    |  LISTE_SR.adr_fin.octet_3 <- LISTE_SR.ss_rsx.octet_3
  |    |    |    |    |    |  LISTE_SR.adr_fin.octet_4 <- LISTE_SR.ss_rsx.octet_4 + ( 2 ^ ( 8 - nbr_bit_addr_octet_mixte ) ) - 2
  |    |    |    |    |  FinSi
  |    |    |    |  FinSi
  |    |    |  Cas "B"
  |    |    |    |  Si numéro_octet_mixte = 3 Alors
  |    |    |    |    |  LISTE_SR.adr_fin.octet_1 <- LISTE_SR.ss_rsx.octet_1
  |    |    |    |    |  LISTE_SR.adr_fin.octet_2 <- LISTE_SR.ss_rsx.octet_2
  |    |    |    |    |  LISTE_SR.adr_fin.octet_3 <- LISTE_SR.ss_rsx.octet_3 + ( 2 ^ ( 8 - nbr_bit_addr_octet_mixte ) ) - 1
  |    |    |    |    |  LISTE_SR.adr_fin.octet_4 <- 254
  |    |    |    |  Sinon
  |    |    |    |    |  LISTE_SR.adr_fin.octet_1 <- LISTE_SR.ss_rsx.octet_1
  |    |    |    |    |  LISTE_SR.adr_fin.octet_2 <- LISTE_SR.ss_rsx.octet_2
  |    |    |    |    |  LISTE_SR.adr_fin.octet_3 <- LISTE_SR.ss_rsx.octet_3
  |    |    |    |    |  LISTE_SR.adr_fin.octet_4 <- LISTE_SR.ss_rsx.octet_4 + ( 2 ^ ( 8 - nbr_bit_addr_octet_mixte ) ) - 2
  |    |    |    |  FinSi
  |    |    |  Cas "C"
  |    |    |    |  LISTE_SR.adr_fin.octet_1 <- LISTE_SR.ss_rsx.octet_1
  |    |    |    |  LISTE_SR.adr_fin.octet_2 <- LISTE_SR.ss_rsx.octet_2
  |    |    |    |  LISTE_SR.adr_fin.octet_3 <- LISTE_SR.ss_rsx.octet_3
  |    |    |    |  LISTE_SR.adr_fin.octet_4 <- LISTE_SR.ss_rsx.octet_4 + ( 2 ^ ( 8 - nbr_bit_addr_octet_mixte ) ) - 2
  |    |  FinSelon
'
on remplit la case dernière adresse : adr_broad --------------------------------------------------------------------------------------------------------------------------------------------
  |    |  Selon classe
  |    |    |  Cas "A"
  |    |    |    |  Si numéro_octet_mixte = 2 Alors
  |    |    |    |    |  LISTE_SR.adr_broad.octet_1 <- LISTE_SR.ss_rsx.octet_1
  |    |    |    |    |  LISTE_SR.adr_broad.octet_2 <- LISTE_SR.ss_rsx.octet_2 + ( 2 ^ ( 8 - nbr_bit_addr_octet_mixte ) ) - 1
  |    |    |    |    |  LISTE_SR.adr_broad.octet_3 <- 255
  |    |    |    |    |  LISTE_SR.adr_broad.octet_4 <- 255
  |    |    |    |  Sinon
  |    |    |    |    |  Si numéro_octet_mixte = 3 Alors
  |    |    |    |    |    |  LISTE_SR.adr_broad.octet_1 <- LISTE_SR.ss_rsx.octet_1
  |    |    |    |    |    |  LISTE_SR.adr_broad.octet_2 <- LISTE_SR.ss_rsx.octet_2
  |    |    |    |    |    |  LISTE_SR.adr_broad.octet_3 <- LISTE_SR.ss_rsx.octet_3 + ( 2 ^ ( 8 - nbr_bit_addr_octet_mixte ) ) - 1
  |    |    |    |    |    |  LISTE_SR.adr_broad.octet_4 <- 255
  |    |    |    |    |  Sinon
  |    |    |    |    |    |  LISTE_SR.adr_broad.octet_1 <- LISTE_SR.ss_rsx.octet_1
  |    |    |    |    |    |  LISTE_SR.adr_broad.octet_2 <- LISTE_SR.ss_rsx.octet_2
  |    |    |    |    |    |  LISTE_SR.adr_broad.octet_3 <- LISTE_SR.ss_rsx.octet_3
  |    |    |    |    |    |  LISTE_SR.adr_broad.octet_4 <- LISTE_SR.ss_rsx.octet_4 + ( 2 ^ ( 8 - nbr_bit_addr_octet_mixte ) ) - 1
  |    |    |    |    |  FinSi
  |    |    |    |  FinSi
  |    |    |  Cas "B"
  |    |    |    |  Si numéro_octet_mixte = 3 Alors
  |    |    |    |    |  
  |    |    |    |    |  LISTE_SR.adr_broad.octet_1 <- LISTE_SR.ss_rsx.octet_1
  |    |    |    |    |  LISTE_SR.adr_broad.octet_2 <- LISTE_SR.ss_rsx.octet_2
  |    |    |    |    |  LISTE_SR.adr_broad.octet_3 <- LISTE_SR.ss_rsx.octet_3 + ( 2 ^ ( 8 - nbr_bit_addr_octet_mixte ) ) - 1
  |    |    |    |    |  LISTE_SR.adr_broad.octet_4 <- 255
  |    |    |    |  Sinon
  |    |    |    |    |  LISTE_SR.adr_broad.octet_1 <- LISTE_SR.ss_rsx.octet_1
  |    |    |    |    |  LISTE_SR.adr_broad.octet_2 <- LISTE_SR.ss_rsx.octet_2
  |    |    |    |    |  LISTE_SR.adr_broad.octet_3 <- LISTE_SR.ss_rsx.octet_3
  |    |    |    |    |  LISTE_SR.adr_broad.octet_4 <- LISTE_SR.ss_rsx.octet_4 + ( 2 ^ ( 8 - nbr_bit_addr_octet_mixte ) ) - 1
  |    |    |    |  FinSi
  |    |    |  Cas "C"
  |    |    |    |  LISTE_SR.adr_broad.octet_1 <- LISTE_SR.ss_rsx.octet_1
  |    |    |    |  LISTE_SR.adr_broad.octet_2 <- LISTE_SR.ss_rsx.octet_2
  |    |    |    |  LISTE_SR.adr_broad.octet_3 <- LISTE_SR.ss_rsx.octet_3
  |    |    |    |  LISTE_SR.adr_broad.octet_4 <- LISTE_SR.ss_rsx.octet_4 + ( 2 ^ ( 8 - nbr_bit_addr_octet_mixte ) ) - 1
  |    |  FinSelon
' -------------- on coimpile les informations puis on les affiches sur l'interface -----------------------------------------------------------------------------------------------------------
  |    |  le_numéros_du_sous_reseaux <- "numéros du sous réseau : " & EnChaîne ( LISTE_SR.num_ss_rsx ) & " ; "
  |    |  ladresse_du_sous_reseaux <- "sous réseau : " & EnChaîne ( LISTE_SR.ss_rsx.octet_1 ) & "." & EnChaîne ( LISTE_SR.ss_rsx.octet_2 ) & "." & EnChaîne ( LISTE_SR.ss_rsx.octet_3 ) & "." & EnChaîne ( LISTE_SR.ss_rsx.octet_4 ) & " ; "
  |    |  la_premiere_machine <- "adresse de début : " & EnChaîne ( LISTE_SR.adr_debut.octet_1 ) & "." & EnChaîne ( LISTE_SR.adr_debut.octet_2 ) & "." & EnChaîne ( LISTE_SR.adr_debut.octet_3 ) & "." & EnChaîne ( LISTE_SR.adr_debut.octet_4 ) & " ; "
  |    |  la_derniere_machine <- "adresse de fin : " & EnChaîne ( LISTE_SR.adr_fin.octet_1 ) & "." & EnChaîne ( LISTE_SR.adr_fin.octet_2 ) & "." & EnChaîne ( LISTE_SR.adr_fin.octet_3 ) & "." & EnChaîne ( LISTE_SR.adr_fin.octet_4 ) & " ; "
  |    |  le_broadcast <- "adresse broadcast : " & EnChaîne ( LISTE_SR.adr_broad.octet_1 ) & "." & EnChaîne ( LISTE_SR.adr_broad.octet_2 ) & "." & EnChaîne ( LISTE_SR.adr_broad.octet_3 ) & "." & EnChaîne ( LISTE_SR.adr_broad.octet_4 ) & " ; "
  |    |  Afficher ( le_numéros_du_sous_reseaux , ladresse_du_sous_reseaux , la_premiere_machine , la_derniere_machine , le_broadcast )
  |    |  x <- x + 1
  |  Jusqu'à x > ( Nbr_sous_reseaux )
  |  
Fin

Un commentaire

Laisser un commentaire