Installer un wallet de alts coin sous Ubuntu 14.04

ubuntu logo

La plupart des wallet sont copié sur le core de bitcoin, une procédure simple est donc possible pour installer les wallet des alts coins qui en découlent. Dans ce billet je prendrai l’exemple du wallet «  » dans une machine virtuelle Ubuntu en 64 bits et version 14.04. (uname -r)

Dans la procédure ci-dessous je décris donc une procédure fonctionnelle afin de compiler un wallet de crypto-monnaie alternatives. (Startcoin, Cravecoin, Cannabis ext …)

Vous permet d’installer les outils Vmwares-tools afin de rendre possible le copier/coller de l’hôte vers la machine virtuelle et inversement.

1
sudo apt-get install open-vm-toolbox open-vm-tools open-vm-tools-dbg

La suite consiste à installer les dépendances afin d’avoir tout les éléments pour compiler les wallets.

1
sudo apt-get install build-essential libssl-dev libdb5.1-dev libdb5.1++-dev libboost-all-dev git qt5-qmake libqt5gui5 libqt5core5a libqt5dbus5 qttools5-dev-tools qt-sdk

La suite de la procédure consiste à compiler le wallet, pour cela rendez-vous dans le dossier que vous venez de cloner via github ou autres. Il doit se trouver un fichier .pro dans le dossier ou vous lancez les commandes de compilation. La compilation peut-être relativement longue suivant la configuration de la machine.

fichier qt dot pro wallet ubuntu

1
2
3
cd crypto-currency/
qmake
make

Informations de debug :

Si vous rencontrez un problème lors du lancement des wallets avec

ubuntu error while loading shared libraries: libdb_cxx-5.3.so

Il faut simplement mettre à jour vos dépendance via

1
2
3
4
#recherche de la dernière version de libdb (actuellement 5)
sudo apt-cache search libdb5
#installation de toutes les paquets
sudo apt-get install libdb5.3-*

Laisser un commentaire