Travaux pratiques sur le protocole OSPF avec Cisco Packet Tracer Partie 2

logo cisco

Dans ce billet je présente la mise en place du protocole OSPF. Il s’agit d’un protocole de routage avec la notion « état de liens« . Ce protocole permet un routage dynamique et au jour de la rédaction de ce billet nous sommes en version « OSPFv2« . Ce protocole est compatible avec IPV6.

Ce protocole fonctionne en étblissent une relation avec ces voisins en envoyant à intervalle régulier un message pour indiquer sa présence. Chaque routeur ayant reçu ce message retourne la liste des réseaux auquel il est connecté (Message de type : LSA). L’ensemble de ces messages LSA va former sur le routeur « source » la « base de donnée de l’état des liens« . (« Link-State Database » LSDB) Suite à cela chaque routeur calcul via l’algorithme « SPF » la route la plus « rapide » vers les différents réseaux retourné dans la LSDB.

Avec ce protocole on va pouvoir « cloisoner » notre réseau dans des « aires ». Voyez cela comme des zones pouvant être indépendante chacune des autres. En résumé dans chaque « aire » que vous allez définir par un routeur « source » vous allez avoir des routes différentes toutes calculées via OSPF.

Pour ce TP je vais utiliser 3 réseaux chacun possedant un client et un routeur. Les modèles utilisés sont Routeur : 2620XMavec un module : NM-4A/S.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Client1 : INT0/0 IPV4 : 192.168.1.0 Paserelle : 192.168.1.254
Client2 : INT0/0 IPV4 : 192.168.2.0 Paserelle : 192.168.2.254
Client3 : INT0/0 IPV4 : 192.168.3.0 Paserelle : 192.168.3.254

Routeur 1 : INT0/0 : 192.168.1.254  Masque : 255.255.255.0
            Serial1/0 : 172.16.1.254 Masque : 255.255.255.0
            Serial1/1 : 172.16.2.254 Masque : 255.255.255.0

Routeur 2 : INT0/0 : 192.168.2.254  Masque : 255.255.255.0
            Serial1/0 : 172.16.3.254 Masque : 255.255.255.0
            Serial1/1 : 172.16.2.253 Masque : 255.255.255.0

Routeur 3 : INT0/0 : 192.168.3.254  Masque : 255.255.255.0
            Serial1/0 : 172.16.3.253 Masque : 255.255.255.0
            Serial1/1 : 172.16.1.253 Masque : 255.255.255.0

0 reseau initiale avant OSPF sur cisco

Configuration Routeur1 Interface Ethernet 0/0

1
2
3
4
5
6
7
8
9
10
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 192.168.1.254 255.255.255.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
R1(config-if)#end
R1#write
Building configuration...
[OK]

Configuration Routeur1 Interface Serie 1/0

1
2
3
4
5
6
7
8
9
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface Serial1/0
R1(config-if)#ip address 172.16.1.254 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1#write
Building configuration...
[OK]

Configuration Routeur1 Interface Serie 1/1

1
2
3
4
5
6
7
8
9
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface Serial1/1
R1(config-if)#ip address 172.16.2.254 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1#write
Building configuration...
[OK]

Répétez cette opération en adaptant la configuration sur chaque routeur. Dans les illustration ci-dessus, je présente la configuration pour le Routeur 1, adaptez avec le routeur 2 et 3 les configurations.

1 reseau interface pour ospf

Pour débuter la configuration de OSPF, on va prend comme routeur source « Routeur1 », le protocole requiert de fournir un ID (RID) à notre routeur source. Il existe plusieurs possibilités pour définir le RID :

  • Configuration manuelle du RID.
  • Sélection automatique de la plus grande adresse IP assignée à une interface loopback.
  • Sélection automatique de la plus grande adresse IP assignée à une interface physique.

Notre réseau tout neuf, il nous suffit de définir une adresse de LoopBack sur notre Routeur1 afin de définir notre RID.

Configuration Adresse lookback sur Routeur1

1
2
3
4
5
6
7
8
9
10
11
Router#conf t
Router(config)#int loopback 0
Router(config-if)#
%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
Router(config-if)#ip address 10.0.1.254 255.255.255.0
Router(config)#end
%SYS-5-CONFIG_I: Configured from console by console
Router#write
Building configuration...
[OK]

Suite à la déclaration de notre RID(Qui deviendra notre routeur « source ») il faut maintenant activer le protocole sur tout les réseaux connectés via nos interfaces series. Pour activer OSPF on va suivre la procédure ci-dessous.

– Déclartation du protocole avec comme identifiant 1
– Déclaration des réseau membres de notre zone

Pour déclarer vos réseaux dans OSPF, déclarez les interfaces connectés à vos interfaces series sur votre routeur « source ».

Configuration OSPF Routeur1

1
2
3
4
5
6
7
8
9
10
11
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#net 172.16.1.0 0.0.0.255 area 0
R1(config-router)#net 172.16.2.0 0.0.0.255 area 0
R1(config-router)#net 192.168.1.0 0.0.0.255 area 0
R1(config-router)#end
R1#write
Building configuration...
[OK]

Configuration OSPF Routeur2

1
2
3
4
5
6
7
8
9
10
11
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#net 172.16.2.0 0.0.0.255 area 0
R2(config-router)#net 172.16.3.0 0.0.0.255 area 0
R2(config-router)#net 192.168.2.0 0.0.0.255 area 0
R2(config-router)#end
R2#write
Building configuration...
[OK]

Configuration OSPF Routeur3

1
2
3
4
5
6
7
8
9
10
11
R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#net 172.16.1.0 0.0.0.255 area 0
R3(config-router)#net 172.16.3.0 0.0.0.255 area 0
R3(config-router)#net 192.168.3.0 0.0.0.255 area 0
R3(config-router)#end
R3#write
Building configuration...
[OK]

Vous pouvez vérifier et éditer votre configuration via les commandes ci-dessous :

– clear ip ospf process : permet de remettre à 0 le process OSPF
– show ip ospf neighbor : affiche les membres de votre zone OSPF
– show ip route : vous permet de suivre l’état de vos routes

On remarque dans la capture d’écran ci-dessous que je peux PING d’un client à un autre, le routage est effectif.

2 ping sucess entre client avec ospf

Scan to Donate Bitcoin
Like this? Donate Bitcoin to at:
Bitcoin 17NmM8q9TC7f4eKczRzHFXTZd39S8K24dv
Donate

Laisser un commentaire

Assemblé dans la station orbitale WordPress